Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Forum » MountainGrafix » Agentur für visuelle Kommunikation in Reutte. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Donnerstag, 27. August 2009, 08:10

Sicherheitscode

Ich traue mich fast nicht diesen Beitrag zu starten aber ich bin durch die Einträge im Forum nicht wirklich schlauer geworden.

Bei mir wird der Sicherheitscode bei der Anmeldung und beim Kontakt nicht angezeigt.

Die Serversoftware besteht aus php 5.2.6 und mysql 5.0.51a.
GD Libary ist verfügbar mit folgenden Werten:

GD Support enabled
GD Version bundled (2.0.34 compatible)
FreeType Support enabled
FreeType Linkage with freetype
FreeType Version 2.3.5
T1Lib Support enabled
GIF Read Support enabled
GIF Create Support enabled
JPG Support enabled
PNG Support enabled
WBMP Support enabled
XPM Support enabled
XBM Support enabled


Ob True Type support aktiviert ist weis ich nicht. Ich vermute jedoch nicht weil ich denke das es dann ebenfalls in der info.php angezeigt würde?

Muss bei fehlendem True Type support wirklich php neu kompiliert werden oder gibt es andere Möglichkeiten.

Könnte es noch an etwas anderem liegen das der Sicherheitscode nicht angezeigt wird?
Von meinen perl scripten kenne ich das die .cgi oder .pl Dateien die Schreibrechte 755 haben müssen. Ist das bei php ebenfalls so?

Besten Dank vorab!

Olli

2

Donnerstag, 27. August 2009, 08:14

Zitat

Ob True Type support aktiviert ist weis ich nicht.

Ohne diese Info braucht man aber eigentlich nicht weitersuchen, denn die TrueType - Unterstützung ist eine zwingende Anforderung und die muss auch erfüllt sein. Wie lautet denn der Link zur Seite?
if ($ahnung == NULL) { read FAQ; use SEARCH; use GOOGLE; } else { use brain; make post; }

3

Donnerstag, 27. August 2009, 20:19

Hallo Herr Schoppengerd.

der Link zur Seite lautet zur Zeit : www.campingwelten.de/markt

Hier die Ausgabe des Diagnose-Tools:

PHP >= 5.1 O.k
- XML Support Verfügbar
- MySQL Support Verfügbar
- Session Support Verfügbar

GD Libary
Extension Verfügbar
Version bundled (2.0.34 compatible)



VG
Olli

4

Freitag, 28. August 2009, 08:21

Hallo Herr Schoppengerd,

ich habe heute Morgen mal ein kleines Script auf dem Server hinterlegt.
Mit diesem soll man testen können ob True Type Support aktiv ist.
Laut Script ist es aktiviert denn die Schrift wird ausgegeben.
Zur Zeit habe ich es auf gabriola.ttf eingestellt.
Ich heb auch mit arial und verdana getestet, die Schriften werden ausgegeben.

www.campingwelten.de/test/ttf.php

VG
Olli

5

Freitag, 28. August 2009, 08:26

Guten Morgen...

vielen Dank für die Info und auch für den Link, doch leider kann ich Ihnen derzeit auch nicht sagen, warum das auf dem Server nicht funktioniert bzw. wo das Problem liegt. Der Sicherheitscode selbst gibt auch keine Fehlermeldung zurück und daher ist es schwierig hier eine Ursache zu finden. Ich vermute mal, dass irgendwo bei der Erstellung des Bildes eine Funktion nicht vorhanden ist oder abweichende Rückgabewerte liefert, doch das kann von hier aus nicht geklärt werden.

Hier müsste man grundsätzlich die gesamte secure.php schrittweise debuggen um das Problem einzugrenzen...
if ($ahnung == NULL) { read FAQ; use SEARCH; use GOOGLE; } else { use brain; make post; }

6

Freitag, 28. August 2009, 19:06

Den ganzen Tag erfolglos getüftelt. Ich bekomme es nicht hin! Der Sicherheitscode wird nicht angezeigt. Eine neue Installation mit den originalen Dateien ohne eigene Änderungen half leider auch nicht. Zum Schluss habe ich bei einer der vielen Neuinstallationen sogar mal ein anderes FTP Programm ausprobiert, weil ich die Idee hatte es könnte an einer fehlerhaften Datenübertragung zum Server liegen.
Hat aber auch keinen Erfolg gehabt. Habe zum testen gerade noch mal ein Script auf den Server geladen das funktioniert auch.

www.campingwelten.de/captcha/captcha.php

Jetzt bin ich wirklich ratlos!


VG
Olli

7

Samstag, 29. August 2009, 01:24

Jetzt bin ich vollkommen cunfused!
Ein Beitrag aus dem mein-easylink.de Forum hat nun den Erfolg gebracht, auch wenn ich das nicht verstehe. Ich kenne das so, dass php, cgi, txt, pl Dateien im ASCII Modus und alle Bilder und Fonts im binären Modus auf den Server übertragen werden. Mein FTP Programm macht dies automatisch weil es so eingestellt ist, dass es eben für die entsprechenden Dateien den entsprechenden Übertragungsmodus wählt. Einen Beitrag aus obigen Forum folgend, habe ich nun das komplette Script, also ALLE Dateien im reinen binären Modus auf den Server übertragen und nun wird der Sicherheitscode plötzlich angezeigt. Kann das jemand verstehen? Also ich verstehe das nicht! Ich würde gerne wissen warum das so ist, einfach aus Neugir.
Bin aber froh das es nun funktioniert!

VG
Olli

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »nostal« (29. August 2009, 01:47)


8

Sonntag, 6. Juni 2010, 14:06

Zitat

Einen Beitrag aus obigen Forum folgend, habe ich nun das komplette

Script, also ALLE Dateien im reinen binären Modus auf den Server

übertragen und nun wird der Sicherheitscode plötzlich angezeigt .
Das war wohl doch nicht der Grund warum der Sicherheitscode plötzlich agezeigt wurde, denn nun habe ich schon wieder das gleiche Problem.
Der Sicherheitscode wird nicht angezeigt, egal in welchem Modus ich die Dateien hochlade.

Hat noch jemand eine Idee?

VG
Olli